Skip to end of metadata
Go to start of metadata

Below is an overview of the general ribbon commands in Enterprise Studio, sorted by functionality.


On this page:


General editing

COMMAND

FUNCTION

Home > Clipboard:

Cut Selection

Remove the selection from the active model, and place it on the Clipboard.

Copy

Copy the selection to the Clipboard.

Paste

Paste

Insert the contents of the Clipboard.

Paste Special

Insert the contents of the Clipboard, with special paste options available:

  • paste as copies
  • paste as copies, matching on name with existing objects

Format Painter

Copy the graphical properties of an object.

Home > Editing:

Find

Advanced find

Search for (specific) elements in the model, diagram or view, or selection.

Editing objects and relations

text layout

COMMAND

FUNCTION

Home > Font:

Font

Change the font face.

Font Size

Change the font size.

Font Color

Change the color of the text.

Rotate label left

Rotate the text in the selected object or relation by 90 degrees left.

Rotate label right

Rotate the text in the selected object or relation by 90 degrees right.

Bold

Make the selected text bold.

Italic

Italicize the selected text.

Underline

Underline the selected text.

Align text left

Align text to the left.

Center

Center text.

Align text right

Align text to the left.

Number

Create a numbered list. Only available for the Documentation pane.

Bullet

Create a bulleted list. Only available for the Documentation pane.

Insert Link

Create a link to a file, web page, model object, or e-mail message. Only available for the Documentation pane.

object and relation markup

COMMAND

FUNCTION

Home > Markup:

Fill Color

Change the fill color of the selected object(s) and relation(s) with a fillable relation endpoint (like an arrowhead).

Transparency

Change the transparency of the selected object(s) and relation(s).

Line Color

Change the color of the selected line(s) of an object, relation, or edge. For objects only available if Derive line color from fill color is deactivated (Enterprise Studio Options, tab Graphics). For relations and edges always available. Not available for node graphics (like junctions).

Line Weight

Change the weight of the selected line(s) of an object, relation, or edge.

Line Style

Change the style of the selected line(s) of an object, relation, or edge.

Hide Icon

Hide the icon displayed in the selected object(s).

Image

Add an image to the selected object(s) and relation(s).

Reset

Reset the graphical attributes of the selected object(s) and relation(s) to their default values.

object and relation layout

COMMAND

FUNCTION

Home > Layout:

Align

          

Align the edges of multiple selected objects: left, right, top, bottom, center, middle, same width, same height, same size, space across, and space down.

Snap to Grid

Snap (a selection of) objects to the closest intersection of the grid.

Grid

Show or hide the grid in the diagram or view.

Guides

Show or hide the drawing guides in the diagram or view.

Grid and Guides

Open the window with grid and guides settings.

Automatic Page Breaks

Show or hide automatic page breaks in the diagram or view.

Attach Label

         

Change the position of the label in the selected object(s): top left corner, top spot, top right corner, left spot, center spot, right spot, bottom left corner, bottom spot, bottom right corner, and outside.

Rotate

Rotate the selected object(s) 90 degrees for horizontal/vertical modeling. Only available for objects displayed with specific graphic shapes, like a cylinder, flow arrow, and trigger.

Right-Angled Lines

Automatically create angles where applicable when drawing lines.

Make Room

Stretch up the selected object to make room for new elements or add space to the diagram or view.

Automatic Layout

Automatic Layout Settings

Automatically lay out the objects and relations in the view. Only available for ArchiMate® views.

Relation Layout

 Layout with Bends

Layout with Right Angles

Layout with Straight Lines

Automatically lay out (a selection of) relations in the view: using bended lines, right angles, or straight lines. Only available for ArchiMate views.

Analysis

view filters

COMMAND

FUNCTION

View > View Filter:

Colors

Generate a color view.

Compare

Generate a compare view.

Relation Colors

Generate a relation color view.

Labels

Generate a label view.

Highlight

Create a highlight view.

Tooltips

Generate a tooltip view.

Relation Roles

Generate a relation roles view.

Show Contents

Show the contents of the selected collapsed object(s).

analysis functions

COMMAND

FUNCTION

View > Analysis:

Show Relations

View the possible relations in the diagram or view, and add them to the model. Only available in ArchiMate, ERD, and UML models.

Advanced > Inspect:

Compare

Compare two selected models or model packages, and show the differences in a workset.

Advanced > Tables:

Derive Relations

View derived relations from the (selected) model via specific profile attributes, or via relations between concepts.

Tables

COMMAND

FUNCTION

Home > Tables:

Properties

Edit user-defined properties in table format.

Cross-references

Profiles

Relations

Cross-model Relations

Edit relations, profile relations, or cross-model relations.

Advanced > Language:

Translation Table

Edit translations of textual properties.

Advanced > Tables:

Links

Edit links in the model.

Diagrams and views

display and zoom

COMMAND

FUNCTION

View > Canvas:

Refresh

Refresh the contents of the current diagram or view.

View Filter Legend

Switch the view filter legend on and off.

Workspace

display tool panes

COMMAND

FUNCTION

Window > Pane:

Messages, Navigator, Viewpoints, Create, Hide, Model Browser, Worksets, Documentation, Properties

Show or hide the pane.

Dock Floating Windows

Dock all floating windows in the Enterprise Studio interface.

arrangement diagrams and views

COMMAND

FUNCTION

Window > Diagram:

Cascade

Arrange the diagrams and views in an overlapping cascade from top to bottom.

Stacked

Arrange the diagrams and views horizontally from bottom to top.

Side by Side

Arrange the diagrams and views vertically from right to left.

Previous Diagram

Go back to the previous open diagram or view.

More Diagrams

Open the Arrange Diagrams window for advanced arranging the open diagrams and views.

Script and inspection

COMMAND

FUNCTION

Advanced > Script:

Query Tool

Create scripts using the built-in script editor and debugger.

Advanced > Inspect:

Scan

Inspect the model package for problems using the Check and Repair function.


ArchiMate® is a registered trademark of The Open Group.